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1.1

System Overview

The many forms of LEDs are the emerging technology for illumination. Fundamental evaluation
and quantification of image appearance as a function of illumination spectrum, intensity, and. incident
angles require a tunable light source. An illumination cavity consisting of a 1 meter diameter hemisphere
is required. The design of the hemisphere enables repeatable positioning of LED clusters. The LED
cluster consist of 1-7 LEDs mounted in a repeatable manner to maximize additivity of output.
The microcontroller being used in this project is the Arduino Duemilanove. It interfaces with
MATLAB to control the outer 6 LEDs of the cluster with an 8-bit output allowing the user to alter the
intensity of a desired LED as needed. The 7th LED, usually white and positioned in the middle, can be
controlled through a digital pin for an on/off position. Only 6 out of the 7 LEDs have an 8-bit control
because each Arduino has 6 PWM outputs. The Arduino also has an additional 8 digital outputs, which
allows the white LED to be digitally controlled. As such, a separate microcontroller is needed for each
LED cluster.

1.2

Project References

Primary Control Designer: Alexander Usachev (Email: axu1402@rit.edu)
Project Team Leader: Nicholas Liotta (nol4939@rit.edu)

1.3

Organization of the Manual

1.0 - General Information
2.0 - MAC Arduino Configuration
3.0 - PC Arduino Configuration
4.0 - MATLAB Arduino Usage

1.4

Acronyms and Abbreviations

LED - light emitting diode
PWM - pulse-width-modulation
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2.1

Arduino Configuration

In order for the MAC to be able to communicate with the Arduino, a FTDI driver needs to be installed.
Due to the fact that the Mac OS X operating system assigns a different port name for each Arduino, this
driver has to be installed each time a new Arduino is connected to the computer.

2.1.1 Driver Installation Mac OS X
After connecting the Arduino to a desired USB port, copy the attached "arduino
"arduino-0022.dmg"
0022.dmg" file to the
computer. Double click on this file and you should see the following screen:

Open the FTDI driver file and continue through the installation process. This should look something very
similar to the process shown below.
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To verify that the driver was installed correctly, type in ls /dev/tty.* or ls /dev/cu.* in the Terminal
window. This should give the following responses:
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Make sure you see a line with the text /dev/tty.usbserial-xxxxx where the xxx's can be anything. Same
for /dev/cu.usbserial-xxxxx. This indicates that the driver installed properly and that the Arduino was
found.

2.1.2 Board/Serial Port Selection
Connect the Arduino board to your computer using the USB cable. The green power LED (labelled
PWR) should go on. Double click the Arduino application. You'll need to select the correct board and
serial port prior to uploading the MATLAB IO package. To select the board, go to Tools > Board. In a
window similar to the one shown below, select Arduino Duemilanove or Nano w/ ATmega328.
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To select the serial port, go to Tools > Serial Port, and select the port you saw in the Terminal window
after installing the FTDI driver. The window should look similar to the one shown below.

2.1.3 MATLAB IO Package Upload
Go to File > Open, and select the "adiosrv.pde" file included in this package. Now go to File > Upload to
I/O Board. Wait a few seconds - you should see the RX and TX LEDs on the board flashing. If the
upload is successful, the message "Done uploading." will appear in the status bar. The process is shown
in the image below.
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USING THE SYSTEM (PC)

3.1

Arduino Configuration

In order for the PC to be able to communicate with the Arduino, a driver needs to be installed. The driver
should only need to be installed once, no matter how many Arduinos are connected.

3.1.1 Driver Installation Mac OS X
After connecting the Arduino to a desired USB port, the driver should be installed automatically on
Windows Vista and Windows 7. On Windows XP, and in the case where the driver is not installed, the
Add New Hardware wizard will open. If the wizard does not open, go to Start > Settings > Control
Panel, and open the wizard manually. When asked Can Windows connect to Windows Update to
search for software? select No, not this time. Click next.

At the next screen, select Install from a list or specific location.
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At the next screen make sure Include this location is selected and browse to the arduino-0022/drivers/
location included in this package. It should copy some files and then come up with the window below.

Almost immediately, another window will pop up, this time it will say USB Serial Port. As before, click
Install from a list or specific location.
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Browse to the arduino-0022/drivers/ again. The installation should complete successfully.

The computer might need to reboot. After it is done rebooting, make sure the Arduino is plugged in (and
the green light is lit). Go to the Device Manager (From the Start Menu, select Settings->Control Panel.
Double click on System and select the Hardware tab. Then click on the Device Manager button).
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Look for an entry under Ports (COM & LPT) that says USB Serial Port (COM) the COM number may
vary but it should be something like COM3 or COM4. The COM stands for "communication", and each
one has a unique number, known as the COM Port number. In this case the COM Port number is
COM3.
If you don't see the COM port verify the Arduino is plugged in, and check that you installed the VCP
FTDI driver.

3.1.2 Board/Serial Port Selection
Connect the Arduino board to your computer using the USB cable. The green power LED (labelled
PWR) should go on. Double click the Arduino application. You'll need to select the correct board and
serial port prior to uploading the MATLAB IO package. To select the board, go to Tools > Board. In a
window similar to the one shown below, select Arduino Duemilanove or Nano w/ ATmega328
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To select the serial port, go to Tools > Serial Port, and select the port you saw in the Device Manager
window after installing the driver. The window should look similar to the one shown below.
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3.1.3 MATLAB IO Package Upload
Go to File > Open, and select the "adiosrv.pde" file included in this package. Now go to File > Upload to
I/O Board. Wait a few seconds - you should see the RX and TX LEDs on the board flashing. If the
upload is successful, the message "Done uploading." will appear in the status bar. The process is shown
in the image below.
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4.1

Arduino Configuration

In order for MATLAB to be able to communicate with the Arduino, the "arduino.m" file included in the
package must be in the working MATLAB folder. The three functions used to control the Arduino,
"DomeInit.m", "DomeSet.m", "DomeClose.m" should also be included in the working folder.

4.1.1 DomeInit
The purpose of the DomeInit function is to instantiate all the Arduinos that will be controlled by
MATLAB. The following code shows the DomeInit function for two Arduinos. This code snippet is used
in the windows environment. If a MAC OS was used, instead of 'COM4', the code would be something
along the lines of '/dev/tty.usbserial-A4001nCf'.
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The function is called using the syntax "DomeInit([1,2])". The completed code contains all 7
microcontrollers which can be called together or separately using their assigned index. The 'pinMode'
commands prepare the associated pins to be used as outputs. Pin 12 is the lone digital output, while 11,
10, 9, 6, 5 and 3 are the PWM outputs. When this command is entered into MATLAB, the user should see
this on the screen:

4.1.2 DomeSet
The DomeSet function sets the intensities of the LEDs of a cluster to the values given. The function takes
two parameters, the cluster number, and the array of intensities. The array of intensities contains 7 values,
where the first is the on/off switch for the white LED, and 2-6 are the intensities for the 8-bit controlled
LEDs. The code below shows the DomeSet function for a system with 2 LED clusters.
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The value of 'b' differentiates between clusters. 'digitalWrite' is used to control the digital LED while
'analogWrite' is used for the 8-bit controlled LEDs. The following image shows what this command looks
like in MATLAB when setting both clusters to the brightest values of all LEDs:

4.1.3 DomeClose
The DomeClose function disconnects the Arduino from MATLAB. As seen in the code below, which is
used for the system with two LED clusters, this function contains one parameter which identifies which
LED cluster needs to be closed.
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The 'delete' method is what disconnects the Arduino from the port it was instantiated with in DomeInit.
The DomeClose function is called using a similar syntax to DomeInit, "DomeClose([1,2])", where the
parameters specify which clusters to disconnect. This is what it looks like in MATLAB:
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4V GEODESIC DOME ASSEMBLY

5.1

Required Materials

The following materials are required for proper assembly of the 4V geodesic dome:
1. Struts
i.
Type A (Quantity: 30 units)
ii.
Type B (Quantity: 30 units)
iii.
Type C (Quantity: 60 units)
iv.
Type D (Quantity: 70 units)
v.
Type E (Quantity: 30 units)
vi.
Type F (Quantity: 30 units)
2. Bolts and corresponding nuts
i.
¼-20 (Quantity: 90 each)
3. Hex key or power drill with driver of appropriate size
4. Wrench of appropriate size

5.2
•
•
•

Assembly Instructions
Assemble the structure as per the construction map provided below.
It is recommended to either build the dome up from the bottom or down from the top.
The dome will not be rigid until each bolt is securely tightened.
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6.1

Machining

6.1.1 Turn Cluster Housing
Turn the O.D. (outside dimension) of the housing to 1.5 inches and the face length to 1 inch.
inch Drill a halfinch through-hole.
hole. Bore 1 inch hole 0.75 inches deep. Then drill and tap hole pattern on top of the cluster
housing to hold the reflector (see Drawing). Drill a hole on the side for the cable.

6.1.2 Turn Reflector
Turn the O.D. to 1.5 inches and face length to 0.375 inches. Drill a hole pattern on the mill and counterbore a 1-inch hole on one side 0.100
.100 inches deep.
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6.1.3 Cut PCB
Rough cut the PCB on a band saw. Then cut on a mill with a hole saw. Afterwards, grind down the PCB
to fit the cluster housing.

6.2

Electrical Assembly

6.2.1 Soldering PCB Connectors
The PCB connectors must be soldered into the board and this process is performed in two steps. For ease
of assembly, the connectors for the ground pat
path should be soldered in first. This is done by placing a
connector into one of the holes on the PCB, flipping the board over while holding the connector in place,
and soldering
dering the connector in place. This process is repeated until all paths to ground have a connector
attached. The second step of this assembly is to solder the co
connectors
nnectors for each signal path to the PCB.
This can easily be done by placing the connectors into the remaining holes and soldering each in place on
the top of the PCB.

6.2.2 Cable Assembly
The cable for this cluster must then be assembled. First, the cable must be cut to the desired length. All
current clusters are constructed with a 12 ft long cable, but any cable length can be used as long as it has
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eight conductors (wires). Each end of the cable should be stripped to expose three to four inches of wires.
At one end of the cable, the wires should be individually stripped and the male pins should be crimped in
place. To increase durability and reliability, each crimp should be soldered to the wire it is attached to.
The connector backing can then be placed onto the cable, to be screwed in place later. The connector can
now be attached to the cable. This is performed by inserting the crimped wires into the CPC connector.
This can be done one at a time by pushing the crimped wire into the connector pin until a "clicking"
sound is heard. This signals that the crimp is inserted far enough to create a secure electrical connection.
Each cable contains 8 different colored wires, which were assigned a number that corresponds to a pin
number on the connector and a location number on the PCB. The one exception to this convention is that
the grey wire is placed in position 8 of the connector and corresponds to the ground connection on the
PCB. The combination used in the current clusters is as follows:
Connector Pin Number
1
2
3
4
5
6
7
8

Male Connector

Color of Wire
Red
Yellow
Green
Brown
Purple
Orange
Blue
Grey

PCB Number
1
2
3
4
5
6
7
GND

Female Connector

6.2.3 Cable/Cluster Integration
Once all crimped wires are inserted into the correct connector pins, the connector backing can be screwed
in place, and the strain relief insert can be added. The last step is to solder the cable wires to the PCB.
The convention explained above is used to determine which wire is attached to each signal line on the
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PCB. When all of the wires are soldered in place, the remaining wire slack can be carefully twisted and
kept inside the cluster housing to provide additional strain relief. At this point, the PCB can be mounted
to the cluster by inserting the three 4-40 screws into every other hole on the cluster.

Cable Harness

6.3

Final Cluster Assembly

6.3.1 LED Placement
The desired LEDs are then chosen and placed into each location on the PCB. Each LED is first marked
with a sharpie or paint marker on the cathode (the flat side of the LED casing, with the shorter lead). This
is done to denote which side should always be placed onto the ground path of the PCB. If a LED is not
oriented in this manner, damage to the LED and/or microcontroller may occur. The leads of the LED are
then trimmed to an appropriate length, and are placed onto the PCB in their desired position. The clusters
were provided with a standard set of LEDs, with the order provided in the list below:
PCB Number
1
2
3
4
5
6
7

LED Color
White
Orange
White
Red
Green
Blue
Yellow

6.3.2 Reflector Attachment
The reflector can then be attached to the cluster housing. This is done by orienting the reflector to tightly
fit over the bolts used to attach the PCB, and pressing it in place. Three 4-40 bolts are then used to firmly
hold the reflector in place.
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6.3.3 Testing
Once a full assembly of the cluster housing is completed, the cluster must be tested. This can quickly be
done by turning each LED on separately (to full intensity), and then all LEDs at once. If everything was
properly soldered and assembled, this should occur with no problems. If any LED does not turn on, a few
simple steps of basic troubleshooting can be performed.
1. Slightly loosen the bolts connecting the reflector to the cluster housing and perform the test
again. Occasionally, too much strain on the cluster will cause a short.
2. Remove the reflector and ensure that all LEDs are placed in the proper orientation. Also
ensure that the LED leads are not too short for the PCB connector.
3. If the problem is still present, a digital multimeter can be used to check if there are any shorts
on the PCB or within the system.

6.3.4 Epoxy Work
When the cluster passes the fully assembled test, certain components must be epoxied to the cluster
housing. Magnets should be epoxied in place on the backside of the cluster housing. The cable entering
the side of the cluster housing should also be epoxied in place.

